评论

收藏

[Linux] OneinStack多版本PHP共存

服务系统 服务系统 发布于:2022-08-01 13:36 | 阅读数:286 | 评论:0

基于《OneinStack》一键PHP/java安装工具中lnmp模式,很多用户希望一个网站运行在php5.4,另一个网站运行在php7,甚至更多版本的php,那么一台服务器上同时支持多个PHP版本应该如何做呢?
1、安装OneinStack选择lnmp模式,默认安装php5.4,安装步骤参考:
选项如下:
Install NginxDo not install Apache
Do not install Tomcat
Install MySQL-5.6
Install php-5.4
....
2、 安装php7
service php-fpm stop            #后面需要再安装php,需要停止phpmv /etc/init.d/php-fpm{,_bk}        #后面需要再安装php会覆盖,备份启动脚本
默认php5.4安装路径是/usr/local/php,如果再次安装会提示php已经安装,因此必须修改options.conf的php安装目录,将php7安装路径设置为/usr/local/php7,修改/root/oneinstack/options.conf:
php_install_dir=/usr/local/php7
再次执行./install.sh,选择Install php-7,其余均选择n
3、修改php配置文件
service php-fpm stop                    #停止php7启动脚本mv /etc/init.d/php-fpm /etc/init.d/php7-fpm         #重命名php7启动脚本mv /etc/init.d/php-fpm_bk /etc/init.d/php-fpm         #恢复php5.4启动脚本
设置php5.4、php7开机自启动:
:
chkconfig --add php7-fpmchkconfig --add php-fpm
chkconfig php7-fpm on
chkconfig php-fpm on
Ubuntu/Debian:
update-rc.d php7-fpm defaultsupdate-rc.d php-fpm defaults
防止php5.4、php7监听sock冲突,修改php7的listen,更改配置文件/usr/local/php7/etc/php-fpm.conf:
listen = /dev/shm/php-cgi.sock          #修改前listen = /dev/shm/php7-cgi.sock         #修改后
手工启动php5.4、php7:
service php-fpm start  #启动php5.4service php7-fpm start #启动php7
如下图:
DSC0000.png

4、 修改nginx虚拟主机配置文件./vhost.sh绑定域名,默认是运行在php5.4,如需要将网站运行在php7下,需要修改/usr/local/nginx/conf/vhost/(改成自己绑定域名):
fastcgi_pass unix:/dev/shm/php-cgi.sock;        #修改前fastcgi_pass unix:/dev/shm/php7-cgi.sock;         #修改后
重新加载nginx,使配置生效:
service nginx reload
原文来自:

评论

使用道具 举报